Page MenuHomekolab.org

Fix deprecation-warning log spam
ClosedPublic

Authored by sicherha on Dec 7 2016, 9:47 PM.

Details

Summary

This patch prevents the iRony logs from being filled up with the following deprecation warning:
PHP Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context

Diff Detail

Repository
rI iRony
Lint
Lint Skipped
Unit
Unit Tests Skipped

Event Timeline

sicherha updated this revision to Diff 750.Dec 7 2016, 9:47 PM
sicherha retitled this revision from to Fix deprecation-warning log spam.
sicherha updated this object.
sicherha edited the test plan for this revision. (Show Details)
sicherha set the repository for this revision to rI iRony.
machniak edited edge metadata.Dec 8 2016, 8:03 AM

What distro are you using? I guess it would be better to update PEAR package. It should not throw warnings with pear-1.10.x.

I didn't know this warning is fixed in newer versions of PEAR - the warning message suggested the opposite. :-)
I'm on Debian 8, which ships an older version of PEAR (see https://packages.debian.org/jessie/php-pear).

So I guess we can scratch this patch and either provide a newer version of PEAR (yay, more packages!) or patch iRony for the distros that ship PEAR < 1.10.1? If possible, I'd favour the latter because I'd like to keep the deviation from distro packages as small as possible (i.e., provide own packages only for functional reasons, not for non-functional ones).

This revision was automatically updated to reflect the committed changes.