Page MenuHomekolab.org

Our baloo package is not installable on fc23
Open, NormalPublic

Description

Our baloo package is not installable:

Error: Transaction check error:

file /usr/bin/balooctl from install of baloo-1:4.14.30.git20150201.0ea73cc-9.2.x86_64 conflicts with file from package kf5-baloo-5.18.0-1.fc23.x86_64
file /usr/bin/baloosearch from install of baloo-1:4.14.30.git20150201.0ea73cc-9.2.x86_64 conflicts with file from package kf5-baloo-5.18.0-1.fc23.x86_64
file /usr/bin/balooshow from install of baloo-1:4.14.30.git20150201.0ea73cc-9.2.x86_64 conflicts with file from package kf5-baloo-5.18.0-1.fc23.x86_64
file /usr/bin/baloo_file from install of baloo-1:4.14.30.git20150201.0ea73cc-9.2.x86_64 conflicts with file from package kf5-baloo-file-5.18.0-1.fc23.x86_64
file /usr/bin/baloo_file_extractor from install of baloo-1:4.14.30.git20150201.0ea73cc-9.2.x86_64 conflicts with file from package kf5-baloo-file-5.18.0-1.fc23.x86_64

Details

Ticket Type
Task

Event Timeline

mollekopf raised the priority of this task from to 60.
mollekopf updated the task description. (Show Details)
mollekopf added a project: KDE PIM.
mollekopf changed Ticket Type from Task to Task.
mollekopf added a subscriber: mollekopf.

There is a general problem that kf5 and non-kf5 versions are not co-installable (so the same probably applies to kdepimlibs and akonadi probably).

The only possible solution is to install into a prefix. So for every distribution that is on kf5, we'll install everything into /opt/kde4/

This would also mean we have to rename all packages, otherwise they are not coinstallable.

vanmeeuwen lowered the priority of this task from 60 to Normal.Thu, Mar 28, 8:13 AM