Page MenuHomekolab.org

Debian Stretch packages are built with wrong Perl version
Closed, ResolvedPublic

Description

This affects cyrus-imapd.

The package is built on a machine where Perl 5.22 is preinstalled, and consequently gets a dependency on perlapi-5.22.2. However, Debian Stretch ships Perl 5.24 - so the dependency is unfulfillable.

I thought this could be resolved by removing the line Preinstall: perl-modules-5.22 from the Debian:9.0 project configuration, but that doesn't seem to have done the trick.

I wonder why the OBS build machines have that old version of Perl in the first place - are they still stuck with an old prerelease of Stretch?

Details

Ticket Type
Task

Event Timeline

Assigning to Jeroen. (Are there any others who also take care of the OBS?)

vanmeeuwen reassigned this task from vanmeeuwen to sicherha.Aug 27 2017, 4:10 PM
vanmeeuwen added a subscriber: vanmeeuwen.

It's just not getting rebuilt automatically. Let's bump something and therefore trigger a rebuild, so that existing installations receive an update too (now possibly preventing an unstable system from being updated to a stable system).

Bumping cyrus-imapd didn't solve the problem, unfortunately - it got built with Perl 5.22 again.

See the build log: https://obs.kolabsys.com/package/live_build_log/home:sicherha:branches:Kolab:16/cyrus-imapd/Debian_9.0/x86_64

OK, this is all me ;-)

vanmeeuwen moved this task from Backlog to Doing on the Stretch board.Sep 11 2017, 7:06 PM

Current Winterfell seems to have it fixed:

apt-cache show cyrus-imapd | grep -i perl
Depends: [...] perl (>= 5.24.1-3+deb9u1), perlapi-5.24.1

sicherha closed this task as Resolved.Sep 18 2017, 3:56 PM