Page MenuHomePhorge

Debian Stretch packages are built with wrong Perl version
Closed, ResolvedPublic


This affects cyrus-imapd.

The package is built on a machine where Perl 5.22 is preinstalled, and consequently gets a dependency on perlapi-5.22.2. However, Debian Stretch ships Perl 5.24 - so the dependency is unfulfillable.

I thought this could be resolved by removing the line Preinstall: perl-modules-5.22 from the Debian:9.0 project configuration, but that doesn't seem to have done the trick.

I wonder why the OBS build machines have that old version of Perl in the first place - are they still stuck with an old prerelease of Stretch?


Ticket Type

Event Timeline

Assigning to Jeroen. (Are there any others who also take care of the OBS?)

vanmeeuwen subscribed.

It's just not getting rebuilt automatically. Let's bump something and therefore trigger a rebuild, so that existing installations receive an update too (now possibly preventing an unstable system from being updated to a stable system).

Bumping cyrus-imapd didn't solve the problem, unfortunately - it got built with Perl 5.22 again.

See the build log:

Current Winterfell seems to have it fixed:

apt-cache show cyrus-imapd | grep -i perl
Depends: [...] perl (>= 5.24.1-3+deb9u1), perlapi-5.24.1