Non-ascii message body IMAP-search doesn't work
Open, 60Public

Description

Hello Kolab Team,

I apologize for if my bug report looks strange. It's my first one here.
I've installed Kolab 16 at CentOS 7. It works fine, but non-ascii body message IMAP serch doesn't work. There are no one messages in search result, though emais with non-ascii (cyrillic in my case) symbols exists in system. I have no clue what's happened. Need help. How to fix issue? This is bug or misconfigure? I think it's bug in cyrus-imap 2.5.10, which shipped to kolab.

[root@kolab ~]# rpm -qv pykolab
pykolab-0.8.7-2.1.el7.kolab_16.noarch

[root@kolab ~]# hostnamectl

 Static hostname: kolab.exampme.com
       Icon name: computer-vm
         Chassis: vm
      Machine ID: c7bd55e523324bd49dd3ba7124af5720
         Boot ID: ae2e08563f604f14b979871ff16d64c3
  Virtualization: vmware
Operating System: CentOS Linux 7 (Core)
     CPE OS Name: cpe:/o:centos:centos:7
          Kernel: Linux 3.10.0-514.21.1.el7.x86_64
    Architecture: x86-64

Details

Ticket Type
Task
ReNDX created this task.Jun 30 2017, 8:30 AM
machniak added a project: Cyrus IMAP.EditedJun 30 2017, 8:51 AM
machniak added a subscriber: machniak.

I can confirm that. In my test it does not find messages even if they use UTF-8/8bit encoding, i.e. no decoding is required. Maybe squatter handles that better, I don't know.

Note that it works for Subject header. So, TEXT/BODY searches do not work for content in message body.

pasik added a subscriber: pasik.Nov 25 2017, 2:30 PM