T2040: Don't call manticore_api when it's not loaded
AbandonedPublic

Authored by dhoffend on Dec 4 2016, 11:56 PM.

Details

Reviewers
None
Group Reviewers
Roundcube Kolab Plugins Developers

Diff Detail

Repository
rRPK roundcubemail-plugins-kolab
Branch
patch/T2040
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 7041
Build 7191: arc lint + arc unit
dhoffend retitled this revision from to T2040: Don't call manticore_api when it's not loaded.Dec 4 2016, 11:56 PM
dhoffend updated this object.
dhoffend edited the test plan for this revision. (Show Details)
dhoffend updated this revision to Diff 735.Dec 5 2016, 12:09 AM

Removed invalid code

Looks like this bug only happens in the old version. The most recent plugins package from Winterfell doesn't have this issue
So I guess this patch isn't really needed. I guess the call for manticore_api is some kind of fallback.

machniak abandoned this revision.Dec 5 2016, 8:26 AM
machniak added a subscriber: machniak.

I don't think we should imitate the editor api if any of manticore_api nor document_editor_api exists. If that happens it's an error anyway. Actually I can think only about one case, the chwala javascript file didn't load. As you can see in https://git.kolab.org/rRPK7adf82a0c6a0b272af8847dedd4b912312141f0e loading the manticore_api was never conditional.

yeah I'm okay with this. I guess it was only a situation where packages were combined in Kolab:16 that didn't played well together. With the upcoming package updates it will be gone.