Page MenuHomePhorge

Upgrade OTP library to spomky-labs/otphp 6.0.x
AbandonedPublic

Authored by bruederli on Nov 20 2016, 9:41 PM.
Tags
None
Referenced Files
F12888576: D272.id653.diff
Mon, Jun 17, 10:01 AM
Unknown Object (File)
Sun, Jun 16, 9:21 AM
Unknown Object (File)
Thu, Jun 13, 9:43 AM
Unknown Object (File)
Fri, Jun 7, 10:43 AM
Unknown Object (File)
Mon, Jun 3, 1:18 AM
Unknown Object (File)
Sat, Jun 1, 11:36 AM
Unknown Object (File)
Sat, Jun 1, 8:31 AM
Unknown Object (File)
Wed, May 29, 4:58 PM
Subscribers

Details

Reviewers
machniak
Summary

This simplifies the integration as we can directly use the
OTPHP\*OTP classes without wrappers

Diff Detail

Repository
rRPK roundcubemail-plugins-kolab
Branch
master
Lint
No Lint Coverage
Unit
No Test Coverage
Build Status
Buildable 6710
Build 6845: arc lint + arc unit

Event Timeline

bruederli retitled this revision from to Upgrade OTP library to spomky-labs/otphp 6.0.x.
bruederli updated this object.
bruederli edited the test plan for this revision. (Show Details)
bruederli added a reviewer: machniak.
bruederli subscribed.
  • Fix adding new factors when list is still empty

According to otphp's composer.json, this change bumps PHP version requirement to at least 5.5.

In D272#3866, @machniak wrote:

According to otphp's composer.json, this change bumps PHP version requirement to at least 5.5.

...which is already end-of-life

Sure, but we still support some versions of Kolab on PHP 5.4 (5.3?), if I'm right. So, it was just a warning from my side to verify by packagers.

Outdated, we're already on otphp v10.