Page MenuHomekolab.org

Upgrade broken on CentOS 7: nodejs and v8
Open, Needs TriagePublic

Description

Hi,
the update on CentOS is further broken. In addition to the broken iRony packages (see task 6817) the nodejs, v8, mongodb-server upgrade is broken because some dependencies are not fulfilled:
LANG=C yum upgrade
Loaded plugins: fastestmirror, priorities, versionlock
Loading mirror speeds from cached hostfile

  • base: ftp.rz.uni-frankfurt.de
  • epel: mirror.nl.leaseweb.net
  • extras: ftp.rz.uni-frankfurt.de
  • updates: mirror.fra10.de.leaseweb.net

94 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package iRony.noarch 0:0.4.5-3.4.el7.kolab_16 will be updated
---> Package iRony.noarch 0:0.4.6-2.4.el7.kolab_16 will be an update
---> Package nodejs-libs.x86_64 1:16.13.2-3.el7 will be obsoleting
--> Processing Dependency: libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) for package: 1:nodejs-libs-16.13.2-3.el7.x86_64
--> Processing Dependency: libcrypto.so.1.1(OPENSSL_1_1_0g)(64bit) for package: 1:nodejs-libs-16.13.2-3.el7.x86_64
--> Processing Dependency: libcrypto.so.1.1(OPENSSL_1_1_1)(64bit) for package: 1:nodejs-libs-16.13.2-3.el7.x86_64
--> Processing Dependency: libcrypto.so.1.1(OPENSSL_1_1_1b)(64bit) for package: 1:nodejs-libs-16.13.2-3.el7.x86_64
--> Processing Dependency: libcrypto.so.1.1(OPENSSL_1_1_1e)(64bit) for package: 1:nodejs-libs-16.13.2-3.el7.x86_64
--> Processing Dependency: libssl.so.1.1(OPENSSL_1_1_0)(64bit) for package: 1:nodejs-libs-16.13.2-3.el7.x86_64
--> Processing Dependency: libssl.so.1.1(OPENSSL_1_1_1)(64bit) for package: 1:nodejs-libs-16.13.2-3.el7.x86_64
--> Processing Dependency: libbrotlidec.so.1()(64bit) for package: 1:nodejs-libs-16.13.2-3.el7.x86_64
--> Processing Dependency: libbrotlienc.so.1()(64bit) for package: 1:nodejs-libs-16.13.2-3.el7.x86_64
--> Processing Dependency: libcrypto.so.1.1()(64bit) for package: 1:nodejs-libs-16.13.2-3.el7.x86_64
--> Processing Dependency: libssl.so.1.1()(64bit) for package: 1:nodejs-libs-16.13.2-3.el7.x86_64
--> Processing Dependency: libuv.so.1()(64bit) for package: 1:nodejs-libs-16.13.2-3.el7.x86_64
---> Package v8.x86_64 1:3.14.5.10-25.el7 will be obsoleted
--> Processing Dependency: libv8.so.3()(64bit) for package: mongodb-server-2.6.12-6.el7.x86_64
--> Processing Dependency: v8(x86-64) < 1:3.15 for package: nodejs-0.12.8-2.36.el7.kolab_16.x86_64
--> Running transaction check
---> Package brotli.x86_64 0:1.0.7-5.el7 will be installed
---> Package libuv.x86_64 1:1.43.0-2.el7 will be installed
---> Package openssl11-libs.x86_64 1:1.1.1k-2.el7 will be installed
---> Package v8.x86_64 1:3.14.5.10-25.el7 will be obsoleted
--> Processing Dependency: libv8.so.3()(64bit) for package: mongodb-server-2.6.12-6.el7.x86_64
--> Processing Dependency: v8(x86-64) < 1:3.15 for package: nodejs-0.12.8-2.36.el7.kolab_16.x86_64
--> Finished Dependency Resolution
Error: Package: nodejs-0.12.8-2.36.el7.kolab_16.x86_64 (@Kolab_16)

Requires: v8(x86-64) < 1:3.15
Removing: 1:v8-3.14.5.10-25.el7.x86_64 (@epel)
    v8(x86-64) = 1:3.14.5.10-25.el7
Obsoleted By: 1:nodejs-libs-16.13.2-3.el7.x86_64 (epel)
    v8(x86-64) = 2:9.4.146.24-3.el7

Error: Package: mongodb-server-2.6.12-6.el7.x86_64 (@epel)

Requires: libv8.so.3()(64bit)
Removing: 1:v8-3.14.5.10-25.el7.x86_64 (@epel)
    libv8.so.3()(64bit)
Obsoleted By: 1:nodejs-libs-16.13.2-3.el7.x86_64 (epel)
   ~libv8.so.9()(64bit)

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Details

Ticket Type
Task

Event Timeline

Spenneberg triaged this task as Needs Triage priority.Jan 26 2022, 9:24 AM

Since nobody is answering:
The reason for the above problem is the fact that apparently the following two packages are obsoleted by EPEL:

yum list obsoletes

Loaded plugins: fastestmirror, priorities, versionlock
Obsoleting Packages
nodejs-libs.x86_64 1:16.14.0-2.el7 epel

v8.x86_64                        1:3.14.5.10-25.el7                    @epel

They would be replaced by more current versions. Unfortunately the nodejs package from Kolab requires these obsoleted packages.

Setting obsoletes=0 in /etc/yum.conf and running "yum update" instead of "yum upgrade" prevents the above problem from occuring.

This comment was removed by sicherha-admin.
This comment was removed by sicherha-admin.
This comment was removed by sicherha-admin.
This comment was removed by brendonc2c.
This comment was removed by sicherha-admin.