Page MenuHomekolab.org

Please add php-endroid-qrcode and php-enygma-yubikey to Kolab16/Jessie
Closed, ResolvedPublic

Description

I'm running Kolab16 on Jessie and tried to enable kolab_2fa, but that failed with:
[24-Jan-2017 22:22:40 Europe/Berlin] PHP Fatal error: Class 'Yubikey\Validate' not found in /usr/share/roundcubemail/plugins/kolab_2fa/lib/Kolab2FA/Driver/Yubikey.php on line 48

I copied php-endroid-qrcode_1.5.4-1_all.deb and php-enygma-yubikey_3.2.0-1_all.deb
from Winterfell and installed the packages. 2FA with my yubikey works after the
initial configuration.

I think we also need dependencies added to roundcubemail-plugins-kolab to get the
packages automatically installed.

Details

Ticket Type
Task

Event Timeline

jh23453 created this task.Jan 24 2017, 10:34 PM
jh23453 added a project: Jessie.

The dependencies were fixes yesterday. 2FA was introduced to Kolab:16 some days ago

https://obs.kolabsys.com/request/show/1937
https://obs.kolabsys.com/request/show/1931

This bug can be closed IMO

jh23453 closed this task as Resolved.Jan 28 2017, 7:53 AM
jh23453 claimed this task.

Thanks - it works for me.